Windows 7 SDK for RtH30 and EiB: Success!


(Max) #21

I’m not sure what you mean by “click on a patch”? Could you maybe elaborate on how you got it to work?


#22

That’s true, I’m glad you noticed that. Perhaps it was not the registry, or maybe that’s only a part of it. I did get it working on Steam by trying a lot of stuff and maybe I forgot a step.

See if you can download and install the latest patch from here, I think it’s v1.03:

Steam should have the latest patch already but perhaps they missed a file or something.

I’m running out of ideas. The last thing to do cross check our installations, but that is tedious and might still not get the answer for us.


(mgs48888) #23

I’m not sure steam has the latest version as I remember 2 additional levels for skirmish that aren’t there in the steam version. My 2 cents.


(Max) #24

Sooo, it has been quite a while but it may be useful to post my succes here!

Today I tried, once again, to get the sdk working.
No matter what I tried, the sdk installer wouldn’t work, so I began searching for a way around and I found it!
I extracted the files from the sdk exe with 7-zip then moved all the files into my “earned in blood / system” folder.
I then ran win7fix.bat (not sure if I needed to), after which I tried to ran UnrealED.exe and to my big surprise IT OPENED UP THE SDK!!
In case I mess up a map or some files I have made an earned in blood folder for the editor (in which I can mess with the maps etc.) and a folder with which I play the game.

Amazing really, I have been trying to get this thing to work for so long…
Now I just have to learn how to use the SDK and how to script so I can edit/make mutators…

I was hoping I could find an easy way to make the flak 88/pak36 usable for my squad but this seems like a lot of work.
I also tried changing the m10 tank model in “run of the mill” to a panzer IV so I could use it with rendroc’s “the germans” mutator but this led to a weird situation where I could command the panzer IV to move and fire/assault enemies but it was marked as an enemy and it would fire its machine gun on me and my squad if we were to walk in front of it. :joy:

Just thought I’d let you guys know!


(Max) #25

You are right btw, the additional levels don’t exist in the steam version. I also can’t patch it whether I try it with 1.01, 1.02 or 1.03.


(Luca Gorosito) #26

I have a problem with the rth30 sdk, when i open it up, a load error occurs that reads:

The following resources were not found when loading the map. Any references to them will be set to NULL.
WARNING: If you save the map now, these references will be saved as NULL

and the missing resources are:
Sound D_LEGGETT.ENEMYSUPPRESSED_A
Sound D_LEGGETT.ENEMYSUPPRESSED_B
Sound D_LEGGETT.ENEMYSUPPRESSED_C
Sound D_LEGGETT.ENEMYSUPPRESSED_D
Sound D_LEGGETT.ENEMYSUPPRESSED_E
Sound D_LEGGETT.ENEMYUNSUPPRESSED_A
Sound D_LEGGETT.ENEMYUNSUPPRESSED_B
Sound D_MAC.OBREISKI_A
Sound D_OBRIESKI.RED_A

and also the left panel with all the tools doesn’t have any icons and i’m forced to guess which one’s which.

i have all the patches installed, i’ve also used the win7fix.bat, even though it happened before i used it, and i also always open unrealed.exe as admin. also, i have the spanish version.


(GASMASK INTENSIFIES) #27

Are they in the files? They might’ve been touched or moved somewhere else. Or Rendroc’s scripts might’ve missed something in links of the files because you use the Spanish version, I can’t be certain about that tho.

Warrior250


(Luca Gorosito) #28

If you mean, if they’re in the sound browser in UnrealEd, then they don’t appear when, for example, i open up leggett’s sounds. Weird.


(Currahee) #29

What kind of tools and program do you used?


(Ice02boy) #30

THANKS, BRO! IT’S WORKING NOW ON WINDOWS 7
GOD BLESS YOU! :smiley: