Windows Sonic was my crash on claptrap dance loading screen

It appears you need to disable any 3-d software from your audio card if you have one.

I still crashed, and then I turned off Windows sonic and it loaded for the first time.

Hope this helps.

3-D sound, turn it off everywhere.

1 Like

Hey @Crimedog75 really good catch.

It might be worth putting in a ticket explaining how you fixed it so the word can spread via the offices (if it hasn’t already).

What I didn’t do: Use bios to disable my F-Xi Titanium and/or turn on hardware sound.

What I did: Turned off all 3-D sound in the software, and turned off Windows Sonic.

My problem: I was getting claptrap loading crash even in DX11.