Workshop tool failures


(Siber) #1

I’ve tried to update a (private) workshop item three times now in the last two days, and each time it works for a long time before coming to a conclusion along the lines of

Uploaded 460,679,072 of 259,130,592 bytes
Steam error updating item: Error code = k_EResultFail

The uncompressed size of the mod dir is 2,416,570368 bytes, and the last built version(which this version shouldn’t be much bigger than) is 542,269,440 bytes. One of my upload attempts went as high as 799,191,552, so what the hell?

Has anyone else hit this, and if so, did you find a work-around?


(Not actually Jesus Christ) #2

Do you have keeper.txt because @Dom2 had the same problem and I think that fixed it?


(Siber) #3

Yes. As far as I recall, missing the keeper file causes a much earlier failure.


(Not actually Jesus Christ) #4

Well, Dom also left it to try again and it worked after a few times…


(Siber) #5

I’ve already tried it three times, and it’s destructive enough to my internet connection for long enough that I’m not going to try again until I go to sleep tonight.


(Taiidan Republic Mod) #6

It took mine about 24 hours the other week. I left it going overnight… I thought it was just because my upload speed was so bad. One thing I found was that it appeared to hang/crash but then recovered if I left it.


(Siber) #7

Uploaded 1,701,803,136 of 238,701,136 bytes
Steam error updating item: Error code = k_EResultFail

The largest upload attempt yet! Now past 4 times the size of the last uploaded version, for no reason I can think of.


(Sastrei) #8

Does the upload tool have a cache file of some type in its directory that might have gotten corrupted?


(Siber) #9

None that I can see.


(Siber) #10

The tool spits out the path to it’s temp dir at the start, so tonight the one that I started up I checked how big the files are. Upload says 309,264,288 to go, size of the bigs is 608,885,818. A moderate filesize bump, expected after some of the changes I made today. I wonder what result I’ll find in the morning!

ed:

Uploaded 613,249,472 of 309,264,288 bytes
Steam error updating item: Error code = k_EResultFail

:expressionless:


(Sastrei) #11

Have you tried the “verify integrity” function for the Workshop tool from Steam’s menu? Does the tool work for any of your other mod directories, or does it fail out for all of them?


(Siber) #12

I only really have the one I’m prepared to test it on, though I suppose I could set something up just for the testing. I hadn’t thought to try a verify on the workshop tool, it didn’t appear to get any results.


#13

I have had problems with the Workshop tool too. I can’t remember if it’s the upload that ends prematurely, or if it is the build.

Usually it works eventually if you keep trying.


(Krnt 13) #14

After 2 months of not updating my mod, I went for it, and seems that I got this same issue, over and over, several attempts.

Uploaded 621,380,288 of 207,642,432 bytes
Steam error updating item: Error code = k_EResultFail

I will keep trying , until I get some good results.
Funny thing is that my addon worked fine previous to the main mod.

Build Operation took 3.62 seconds.

Updating item on Steam Workshop…
Uploaded 127,744 of 127,744 bytes
Workshop item updated.

EDIT: after many tries is still giving me issues, I think that the increased amount of bytes transferred is due to the software attempting automatically, and may be related to an unstable internet connection.

Is not the first time it happens to me, but is the first time it happens so many times without succeeding.

Updating item on Steam Workshop…
Uploaded 205,087,712 of 205,087,712 bytes
Steam error updating item: Error code = k_EResultFail

This was my last try, I will keep on until it succeeds, my subscribers are telling me that they are unable to download, so I will have to look for an temporary alternative solution for this.

EDIT2:
I’ve been so blind, I didn’t saw that the file was too small because it should be 1,215,229,984 bytes, so the issue, at least for me, must be because its failing to compile the entire data, anyway I’m going back to ModDB to upload it for now.

EDIT3: I forgot that the Workshop tool only updates the necessary files, but still seems that the compiling process has something wrong, because the compiled data sizes are not consistent in each attempt.


(Siber) #15

Yeah, I assume we can still distribute mods the old way, and that might be a worthwhile backup option while the workshop tool is being a pain. I’m willing to bet your audience will be a lot smaller that way, though.


(Krnt 13) #16

I’ve been thinking of using the “create” command rather than the “update” one but I’m kind of afraid that it messes up the old page, would this overwrite the old content and fix the issue or it will duplicate the mod?


(Siber) #17

I would expect it to make another mod. I’d back up your current config file first and give it a shot, I guess.


(Taiidan Republic Mod) #18

I had to try 7 or 8 times over a 12 hour period, with a relatively small big file. Perseverance eventually paid off, so it seems that the answer is “just keep trying and it might work in the end”


(Krnt 13) #19

That is very bad news to me, my Internet service is in the worst shape ever since the last time I posted, and that means I wouldn’t be able to update my mod, mostly because of my ISP incompetence, but the workshop tool situation doesn’t help me, I will try next time I change ISP.


(Siber) #20

one thing I’ve considered is taking a laptop to a coffee shop or internet caffe or some establishment of that sort to upload the mod. I don’t know you’re area, so no idea if it’s an option for you, but it’s a thought.