"your settings have failed to save. would you like to try saving again?"

This error is so frustrating. I’ve found that others are having this error as well and I tried the fixes that worked for them but they didn’t work for me. The game was running perfectly until I moved the install drive to my external hard drive. I moved it with steam, not just by dragging it in a file manager so I thought it would be fine. I even tried moving it back or re-installing the game. Nothing has worked.

information about my system:
CPU: i5-2320
GPU: GTX 1050 ti
RAM: 16GB
OS: Pop!_OS

Additional information: I was running the game on windows but after I beat it and started playing on tvhm the game would crash after about 10 minutes or so and lock up the entire system. I installed Linux and played Borderlands 3 with better performance and no system crashes. All until I moved the installation drive. I think the game expects the save to be somewhere else and it’s not. I’m really not sure. All I know is it can’t be file-permission’s because I’ve tested almost every other game on that drive and they can all run and save just fine.