Zane's Drone Delivery not working?

I just tried using this skill with Zane for the first time, but the drone never drops a grenade on my enemies, like at all.

I’m currently using a Vladof grenade mod that explodes on impact, splits into 2 grenades in flight, with each grenade spawning 3 grenades when they detonate, in case you’re wondering.

Can anyone else confirm this?

1 Like

I just wanted to add that I’m playing on PC, my game is fully patched up and I tried a different grenade mod, but the SNTNL still wont work for me…

I even tried with no grenade mods at all, and the drone doesn’t drops any grenade at all.

it is working fine [PC}

working fine for me on ps4. that random hex explosion when the drone is off in the distance is a definate sign.

Well, for me it’s not working at all, or I’m missing something here…

The SNTNL will drop a free grenade automatically with Drone Delivery, and this grenade will be the same as the grenade mode I’m using, right?

its the same grenade for sure. seems to be fairly random as to when it actually drops the grenade though.

Not for me, it always drops one as soon as it acquires it’s first target. Then it’s on cooldown for x seconds.

It’s aim isn’t always great though and the type of detonation and delivery play a big part in it’s effectiveness.

Ok, so I started the game today and the drone started to drop grenades now…

I sincerely don’t know what happened, but I’m 100% sure the drone wasn’t dropping grenades at all, because I tested it by removing every skill augment and only used it to attack enemies, and the skill wasn’t working.

I’m pretty sure there’s a bug somewhere that will make this skill not work, but I don’t know what exactly causes it.

Could the sudden “now working” status be something to do with one of the hotfixes not being applied previously?

That would be my first guess if something wasn’t working, then suddenly it is.

Edit: They need to be re-applied on every restart, so that’s why I’m suggesting it as a possibility.

I know this is an old topic but I recently encountered the exact same problem. I am using the Fishslap grenade with corrosive. It is very easy to see when it is dropped, but in certain map areas it most definitely is not being dropped by the STNL. If I am farming Xam in Xylourgos I have virtually infinite ammo from the drone drops and the grenade mod. On the other hand, when in the Cathedral of the Gods, packed full of bandits I run out of ammo in minutes. I have watched very carefully with zero ammo and even though the STNL is visibly attacking bandits it definitely did not drop a grenade.

1 Like

i have excatly the same problem since the last update. before the update i always see the mirv hex flying around when i’m using SNTL with the Shield. Now no grenade seems to spawn. the fishslap didin’t work, the it’s pissed, the mirv hex or cloning hex, epicenter.

i just reset my skills, but i have the same problem again :-/ no granades from SNTL anymore :frowning:

1 Like

okay, i reset my drone from the action skill, remove the grenade, move the SNTL again to action skill, take my grenade, started the SNTL und finally the grenades are back.

i also tried to reset my whole build, but this din’t helped.

but i’m not sure if the grenade from SNTL are proccing in all areas… i’ve to try more areas.

1 Like

This just started happening to me as well, worked fine yesterday but today no grenades dropping. I’ve tried respeccing, unequipped and reequipped both grenade and action skill and nothing. Restarted game and applied hotfixes. Nothing seems to work.


I’ve noticed this happening to me as well just now. Drone delivery just does not work on the villa ultraviolet map. It works fine in the compactor and also when I was farming killavolt. Not sure why it’s only certain areas. If it matters, I’m using a fishslap.


I’m pretty sure that I’ve had this working in the Cartel village previously but I could be mistaken. I just ran through the beginning and Drone Delivery didn’t work at all. I’m also using a Fish Slap with a Cutpurse and my build depends on it with the bullet sponge mobs on M10.

Looks like I can’t do the Villa either. Put it on the list of many things that are broken in this game.

I went to Ambermire and Drone Delivery is working just like it’s supposed to.

1 Like

I always equip a homing grenades so that “aim” from SNTL doesn’t matter.


I’m also reliant on the fishslap/cutpurse combo which is why I noticed something was wrong pretty quickly. So far I’ve only seen this problem in the cartel villa so I’m not surprised it works in Ambermire. I do hope this gets fixed in the next patch.

1 Like

I hope so. I’d like to be able to farm the Cartel Villa before the event is over.

I still farm the villa, it’s just more of a pain since I need to melee the mobs myself rather than rely on the drone like everywhere else.

I keep my fingers crossed for y’all to drop a well rolled cutpurse launchpad or cutpurse rocket boots. It’ll change your way of playing like nothing else.